Podtrics User Portal Degraded
Incident Report for Podtrics
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 12:52 CDT
Investigating
There is currently an issue with the Podtrics User Portal. We are aware of this issue and are actively working to resolve it.
Posted Jul 12, 2021 - 10:17 CDT
This incident affected: Podtrics User Portal.